Author Topic: Issue installing and running on Linux  (Read 3926 times)

Carroto

  • Newbie
  • *
  • Posts: 5
  • Inf: +0/-0
    • View Profile
    • Awards
Issue installing and running on Linux
« on: February 21, 2023, 11:43:18 am »
First of all I'm using a non-standard patcher, so I'm not necessarily expecting anything, but I'm curious if anyone might have any insight into the behavior I'm seeing.  I'm using https://github.com/Matt-Fitzpatrick/etoh-downloader, which I've used on other servers without any problems.  Running the patcher everything seems to run fine and I run the downloaded Rebirth.exe under wine and I get this:

Quote
./rebirth/rebirth_bin.pigg: Bad flag on file - not a Pig file-1

Your data might be corrupt, please run the patcher and try again.

So I look and I see that the file is there but has a file size of zero.  I download the file manually and get the same thing.  I examine the manifest and it shows the file having a size of zero.  So everything agrees the file should be empty, but the game client complains about it.  I'm confused about what might be going on here.

Profit

  • Developer
  • Newbie
  • *****
  • Posts: 12
  • Inf: +2/-0
    • View Profile
    • Awards
Re: Issue installing and running on Linux
« Reply #1 on: March 09, 2023, 07:30:00 pm »
I'm a little late to the party but it sounds like that launcher isn't removing 0kb files and it should be. I have a powershell launcher here on the forums I believe and since you can sudo apt-get powershell now it might work better for you and does remove 0kb files.

Carroto

  • Newbie
  • *
  • Posts: 5
  • Inf: +0/-0
    • View Profile
    • Awards
Re: Issue installing and running on Linux
« Reply #2 on: April 29, 2024, 11:01:53 pm »
Quote
it sounds like that launcher isn't removing 0kb files and it should be.

I wish I'd checked back again sooner because you're right.  I finally came back and tried again and deleted empty files and it ran just fine.  Well mostly.  The one issue I'm having is a lack of light on many indoor maps.  I'm running under wine on Linux but I'm able to do this with other CoH servers in the same wine prefix without this problem, so it doesn't seem to be a problem with wine generally.

If anyone has any ideas for things I could try I'd appreciate it.  I'm 99.9% of the way there but not being able to see on indoor maps is likely going to be a showstopper for me here.  I tried sort of randomly playing with graphics settings in the hope that maybe the problem was specific to one setting at one value but nothing I tried made a difference there.

 
Screenshot_20240429_200919.png